Back to overview
Resolved
DDoS protection PletX, NL-PDC2-MCN-GAME-B06, and 1 other service are down
Aug 23, 2026 at 8:31pm UTC
Affected services
DDoS protection PletX
NL-PDC2-MCN-GAME-B06
NL-PDC2-MCN-GAME-P03
Resolved
Aug 23, 2026 at 8:33pm UTC
DDoS protection PletX, NL-PDC2-MCN-GAME-B06, and NL-PDC2-MCN-GAME-P03 recovered.
Affected services
Created
Aug 23, 2026 at 8:31pm UTC
DDoS protection PletX, NL-PDC2-MCN-GAME-B06, and NL-PDC2-MCN-GAME-P03 went down.
Affected services